码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4696 Answers 乱搞

时间:2014-10-24 20:52:40      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   java   for   


乱搞:

rt,有1就能输出所有的数,否则只能输出偶数

Answers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 489    Accepted Submission(s): 294


Problem Description
bubuko.com,布布扣
 

Sample Input
2 4 2 2 2 1 0 1 2 3
 

Sample Output
NO YES YES YES
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m;
int t[100100],c[100100];

int main()
{
  while(scanf("%d%d",&n,&m)!=EOF)
    {
      bool flag=false;
      for(int i=1;i<=n;i++)
        scanf("%d",t+i);
      for(int i=1;i<=n;i++)
        {
          scanf("%d",c+i);
          if(c[i]==1) flag=true;
        }
      for(int i=0;i<m;i++)
        {
          int x;
          scanf("%d",&x);
          if(x<=0) puts("NO");
          else
            {
              if(flag) puts("YES");
              else
                {
                  if(x%2==0) puts("YES");
                  else puts("NO");
                }
            }
        }
    }
  return 0;
}



HDOJ 4696 Answers 乱搞

标签:des   style   http   color   io   os   ar   java   for   

原文地址:http://blog.csdn.net/ck_boss/article/details/40431827

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!