码迷,mamicode.com
首页 > 其他好文 > 详细

[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher :G - Power Strings POJ - 2406(kmp简单循环节)

时间:2019-08-15 22:45:35      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:rip   get   字符   就是   next   mes   iostream   output   out   

[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher

G - Power Strings

POJ - 2406

题目:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:求字符串的循环节个数
思路:要注意如果该字符串如果不满足都是循环组成的则输出-1,若是都是循环节组成的,那么n-nextt[n]就是循环节长度,用总长度除以这个长度就是循环节长度
 
// 
// Created by HJYL on 2019/8/15.
//
#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
using namespace std;
const int maxn=1e7+10;
char str[maxn];
int nextt[maxn];
void getnextt()
{
    int i=0,j=-1;
    nextt[0]=-1;
    int n=strlen(str);
    while(i<n)
    {
        if(j==-1||str[i]==str[j])
        {
            i++,j++;
            if(str[i]!=str[j])
                nextt[i]=j;
            else
                nextt[i]=nextt[j];
        } else
            j=nextt[j];
    }
}
int main()
{
    //freopen("C:\\Users\\asus567767\\CLionProjects\\untitled\\text","r",stdin);
    while(~scanf("%s",str))
    {
        if(str[0]==‘.‘)
            break;
        int len=strlen(str);
        getnextt();
        if(len%(len-nextt[len])==0)
         printf("%d\n",len/(len-nextt[len]));
        else
            printf("1\n");
    }
    return 0;
}

 

 

 
 

[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher :G - Power Strings POJ - 2406(kmp简单循环节)

标签:rip   get   字符   就是   next   mes   iostream   output   out   

原文地址:https://www.cnblogs.com/Vampire6/p/11360900.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!