码迷,mamicode.com
首页 > 其他好文 > 详细

Oulipo POJ - 3461(kmp,求重叠匹配个数)

时间:2019-08-16 12:03:36      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:iso   space   roman   hat   lis   air   rac   fir   was   

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …,‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

 题意:

给出T组数据,每组数据有两个字符串,让我们查找第一个字符串在第二个字符串中出现的次数,可重叠;

思路:kmp;

注意:使用C++中cin、cout作为输入输出语句将导致超时,也是怪坑的

具体代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxx 2000100
char a[maxx],b[10100];
int n,m;
int p[maxx];
void pre()
{
    int i=0,j=-1;
    p[0]=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            j++,i++;
            p[i]=j;
        }
        else
            j=p[j];
    }
}
void kmp()
{
    int i=0,j=0,ans=0;
    while(i<n)
    {
        if(j==-1||a[i]==b[j])
        {
            i++,j++;
            if(j==m)
            {
                ans++;
                j=p[j];
            }
        }
        else
            j=p[j];
    }
    printf("%d\n",ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",b,a);
        n=strlen(a);//
        m=strlen(b);
        pre();
        kmp();
    }
    return 0;
}

 

Oulipo POJ - 3461(kmp,求重叠匹配个数)

标签:iso   space   roman   hat   lis   air   rac   fir   was   

原文地址:https://www.cnblogs.com/dwj-2019/p/11362847.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!