标签:des style blog color io os ar java for
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12157 Accepted Submission(s): 5036
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct st
{
int l,w;
}data[10050];
int cmp(st a,st b) //按木头长度从长到短排序,若长度一样则按质量从大到小排序。
{
if(a.l!=b.l)
return a.l>b.l;
else
return a.w>b.w;
}
int a[10050];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j,n,k,sum=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d %d",&data[i].l,&data[i].w);
}
sort(data,data+n,cmp);
memset(a,0,sizeof(a));
for(i=0;i<n;i++) //将遍历过的且满足条件的木头做标记,用sum统计所需要的次数。
{
if(a[i])continue;
k=data[i].w;
for(j=i+1;j<n;j++)
{
if(k>=data[j].w&&!a[j])
{
k=data[j].w;
a[j]=1;
}
}
sum++;
}
printf("%d\n",sum);
}
}
Wooden Sticks(杭电1051)
标签:des style blog color io os ar java for
原文地址:http://blog.csdn.net/hdd871532887/article/details/40453327