码迷,mamicode.com
首页 > 其他好文 > 详细

poj3070--Fibonacci(矩阵的快速幂)

时间:2014-10-25 17:21:23      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   os   ar   for   strong   

Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9650   Accepted: 6856

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

bubuko.com,布布扣.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

bubuko.com,布布扣.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

bubuko.com,布布扣.

Source

和普通的快速幂的写法相同,不同的是需要计算矩阵相乘,只要写对矩阵的乘法,就没难度了
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define LL long long
struct node{
    LL s11 , s12 , s21 , s22 ;
};
node f(node a,node b)
{
    node p ;
    p.s11 = (a.s11*b.s11 + a.s12*b.s21)%10000 ;
    p.s12 = (a.s11*b.s12 + a.s12*b.s22)%10000 ;
    p.s21 = (a.s21*b.s11 + a.s22*b.s21)%10000 ;
    p.s22 = (a.s21*b.s12 + a.s22*b.s22)%10000 ;
    return p ;
}
node pow(node p,int n)
{
    node q ;
    q.s11 = q.s22 = 1 ;
    q.s12 = q.s21 = 0 ;
    if(n == 0)
        return q ;
    q = pow(p,n/2);
    q = f(q,q);
    if( n%2 )
        q = f(q,p);
    return q ;
}
int main()
{
    int n ;
    node p ;
    while(scanf("%d", &n) && n != -1)
    {
        p.s11 = p.s12 = p.s21 = 1 ;
        p.s22 = 0 ;
        p = pow(p,n);
        printf("%d\n", p.s12);
    }
    return 0;
}

poj3070--Fibonacci(矩阵的快速幂)

标签:des   style   blog   http   io   os   ar   for   strong   

原文地址:http://blog.csdn.net/winddreams/article/details/40454195

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!