标签:des style http color io os ar for sp
Problem Description
A school bought the first computer some time ago(so this computer‘s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the
net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also
get S4 = 4, S5 = 4.
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected
and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
Sample Input
Sample Output
在一个树种求每个点的最长路:
dp[x]表示经过边x的最长路..
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const int maxn=10010;
struct node{
int u,v;
int w;
int next;
}e[maxn<<1];
int head[maxn];
int dp[maxn<<1];
int n,cnt;
void add(int u,int v,int w)
{
e[cnt].u=u;e[cnt].v=v;
e[cnt].w=w;e[cnt].next=head[u];
head[u]=cnt++;
}
int dfs(int u,int p)
{
int ans=0;
for(int i=head[u];~i;i=e[i].next)
{
int v=e[i].v;
if(v==p) continue;
if(dp[i]==0) dp[i]=dfs(v,u)+e[i].w;
ans=max(ans,dp[i]);
}
return ans;
}
int main()
{
int x,y;
while(~scanf("%d",&n))
{
CLEAR(head,-1);
CLEAR(dp,0);
cnt=0;
REPF(i,2,n)
{
scanf("%d%d",&x,&y);
add(i,x,y);
add(x,i,y);
}
for(int i=1;i<=n;i++)
printf("%d\n",dfs(i,i));
}
return 0;
}
HDU 2196 Computer(树形DP求最长路)
标签:des style http color io os ar for sp
原文地址:http://blog.csdn.net/u013582254/article/details/40454531