码迷,mamicode.com
首页 > 其他好文 > 详细

Aggressive cows (USACO 2005 February Gold) (二分查找)

时间:2019-08-27 21:27:16      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:src   any   scan   agg   技术   while   minimum   描述   close   

描述Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don‘t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?输入* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi输出* Line 1: One integer: the largest minimum distance样例输入

5 3
1
2
8
4
9

样例输出

3

提示OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

 

技术图片
#include <iostream>
#include <algorithm>
using namespace std;
int n,k;
int a[100000+5],b[ 100000+5];
int fun(int m)
{
    int cnt=0;
    while(m)
    {
        if(m%2) cnt++;
        m>>=1;
    }
    return cnt;
}
int judge(int m)
{
    int cnt=1,temp=a[0];//第一个位置有牛 
    for(int i=1;i<n;i++)
    {
        if(a[i]-temp>=m) 
        {
            temp=a[i];
            cnt++;
        }
    }
    if(cnt>=k) return 1;
    else return 0;
}
void solve()
{
    int l=0,r=a[n-1]-a[0];//距离 
    while(l<=r)
    {
        int mid=l+(r-l)/2;
        if(judge(mid))  l=mid+1;
        else r=mid-1;
    } 
    cout<<l-1<<endl;
    return ;
}
int main()
{
    while(cin>>n>>k)
    {
        for(int i=0;i<n;i++) cin>>a[i];
        sort(a,a+n);
        solve();
    }
    return 0;
} 
View Code

 

Aggressive cows (USACO 2005 February Gold) (二分查找)

标签:src   any   scan   agg   技术   while   minimum   描述   close   

原文地址:https://www.cnblogs.com/Shallow-dream/p/11420640.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!