码迷,mamicode.com
首页 > 其他好文 > 详细

N!(杭电1042)

时间:2014-10-25 21:37:23      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   os   ar   java   for   

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55971    Accepted Submission(s): 15886


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6
#include<stdio.h>
int main()
{
	int i,j,n,m;
	while(scanf("%d",&n)!=EOF)
	{
		if(n<0)
		{ 
		   continue;
	    }
		int str[10000]={0};
		str[0]=1;
		m=0;
		for(i=1;i<=n;i++)//m用来控制进位。 
			for(j=0;j<=m;j++)
			{
				str[j]=str[j]*i;
				if(j>0&&str[j-1]>=10000)
				{
				   str[j]=str[j]+str[j-1]/10000;
				   str[j-1]=str[j-1]%10000;
			    }
			    if(str[m]>=10000)
			       m++;
			}
		printf("%d",str[m]);   
		for(i=m-1;i>=0;i--)
		    printf("%04d",str[i]);
		printf("\n");
	}
	return 0;
}


N!(杭电1042)

标签:des   style   blog   color   io   os   ar   java   for   

原文地址:http://blog.csdn.net/hdd871532887/article/details/40456071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!