码迷,mamicode.com
首页 > 其他好文 > 详细

【模拟】1.Vigenère 密码

时间:2014-10-25 22:54:27      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   使用   

题目描述 Description

16 世纪法国外交家Blaise de Vigenère设计了一种多表密码加密算法——Vigenère密码。Vigenère 密码的加密解密算法简单易用,且破译难度比较高,曾在美国南北战争中为南军所广泛使用。

在密码学中,我们称需要加密的信息为明文,用 M 表示;称加密后的信息为密文,用C 表示;而密钥是一种参数,是将明文转换为密文或将密文转换为明文的算法中输入的数据,记为k。 在Vigenère密码中, 密钥k是一个字母串, k=k1k2…kn。当明文M=m1m2…mn时,得到的密文C=c1c2…cn,其中ci=mi®ki,运算®的规则如下表所示:

 

Vigenère加密在操作时需要注意:

 

1.  ®运算忽略参与运算的字母的大小写,并保持字母在明文 M中的大小写形式;

 

2.  当明文M的长度大于密钥k的长度时,将密钥k 重复使用。

 

例如,明文M=Helloworld,密钥k=abc 时,密文C=Hfnlpyosnd。

 

明文

H

e

l

l

o

w

o

r

l

D

密钥

a

b

c

a

b

c

a

b

c

a

密文

H

f

n

l

p

y

o

s

n

d

                                                                        bubuko.com,布布扣
输入描述 Input Description

输入共2行。

第一行为一个字符串,表示密钥k,长度不超过100,其中仅包含大小写字母。第二为一个字符串,表示经加密后的密文,长度不超过1000,其中仅包含大小写字母

输出描述 Output Description

输出共1行,一个字符串,表示输入密钥和密文所对应的明文

样例输入 Sample Input

CompleteVictory

Yvqgpxaimmklongnzfwpvxmniytm

样例输出 Sample Output

Wherethereisawillthereisaway

数据范围及提示 Data Size & Hint

对于 100%的数据,输入的密钥的长度不超过 100,输入的密文的长度不超过 1000,且都仅包含英文字母。

 

 

纯净水

# include<cstdio>
# include<cstring>
# include<cctype>
# include<algorithm>
using namespace std;
const int maxn=300;
char map[maxn][maxn],ms[3000],word[3000];
int main(){
    freopen("vigenere.in","r",stdin);
    freopen("vigenere.out","w",stdout);
    for(int i=A;i<=Z;i++){
        int temp=A;
        for(int j=i,k=1;k<=26;k++,j++){
                if(j==Z+1)j=A;
                map[i][j]=temp++;
        }
    }
    scanf("%s\n",ms);
    scanf("%s",word);
    int len=strlen(ms);
    int cur=0;
    for(int i=0;i<strlen(word);i++){
        if(word[i]>=A&&word[i]<=Z)
        printf("%c",toupper(map[toupper(ms[cur++])][toupper(word[i])]));
        else printf("%c",tolower(map[toupper(ms[cur++])][toupper(word[i])]));
        if(cur==len)cur=0;
    }
    return 0;
}

 

 

 

【模拟】1.Vigenère 密码

标签:des   style   blog   http   color   io   os   ar   使用   

原文地址:http://www.cnblogs.com/zoniony/p/4050941.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!