码迷,mamicode.com
首页 > 其他好文 > 详细

概率dp HDU 4405

时间:2014-10-25 23:06:30      阅读:438      评论:0      收藏:0      [点我收藏+]

标签:概率dp

Aeroplane chess
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 
 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
 

Sample Input

2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output

1.1667 2.3441
 

题意:Hzz在玩一种游戏,在N+1个格的图上,初始在0处,每次掷一枚骰子,骰子有6个标有1,2,3,4,5,6的面,每次前进最上面的那个面上所标的数步。有些地方有道具,到达之后它可以使用道具直接到达yi处,而不用掷骰子。求到达终点掷骰子的期望。

/*************************************************************************
    > File Name: t.cpp
    > Author: acvcla
    > Mail: acvcla@gmail.com 
    > Created Time: 2014年10月21日 星期二 21时33分55秒
 ************************************************************************/
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
#include<ctime>
#include<set>
#include<math.h>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define pb push_back
double dp[maxn];
int y[maxn],n,m;
int main(int argc, char const *argv[])
{
	while(~scanf("%d%d",&n,&m)){
		if(!n&&!m){
			return 0;
		}
		n++;
		memset(dp,0,sizeof dp);
		memset(y,0,sizeof(y));
		int x,to;
		for(int i=1;i<=m;i++){
			scanf("%d%d",&x,&to);
			y[x+1]=to+1;
		}
		for(int i=n-1;i>=1;i--){
			double t=0;
			for(int j=1;j<=6;j++)t+=dp[i+j]/6;
			if(y[i]){
				t=dp[y[i]]-1;
			}
			dp[i]=t+1;
		}
		printf("%.4f\n",dp[1]);
	}
	return 0;
}




概率dp HDU 4405

标签:概率dp

原文地址:http://blog.csdn.net/acvcla/article/details/40457351

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!