码迷,mamicode.com
首页 > 其他好文 > 详细

概率dp HDU 3853

时间:2014-10-25 23:06:28      阅读:440      评论:0      收藏:0      [点我收藏+]

标签:概率dp

H - LOOPS
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 
bubuko.com,布布扣

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 




 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 


 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 

 

Sample Input

2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output

6.000
 

题意:一个R*C的矩阵,起点在(1,1),终点在(R,C),告诉你在每个点在原地,向右,向下的概率,每次花费2个能量去移动(呆在原地也可),求到达终点的能量花费期望。

本题需要注意题目说期望小于1e6,那么呆在那个点的概率为1的点肯定从起点出发不可达的点。否则期望会无穷大。

dp[i][j]表示从(i,j)到(r,c)所需要的期望能量。


/*************************************************************************
    > File Name: t.cpp
    > Author: acvcla
    > Mail: acvcla@gmail.com 
    > Created Time: 2014年10月21日 星期二 21时33分55秒
 ************************************************************************/
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
#include<ctime>
#include<set>
#include<math.h>
using namespace std;
typedef long long LL;
const int maxn = 1e3 + 10;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define pb push_back
double dp[maxn][maxn];
int r,c;
double Div(int a,int b){
	return double(a)/b;
}
struct p
{
	double p1,p2,p3;
}P[maxn][maxn];
int main(int argc, char const *argv[])
{
	while(~scanf("%d%d",&r,&c)){
		for(int i=1;i<=r;i++){
			for(int j=1;j<=c;j++){
				scanf("%lf%lf%lf",&P[i][j].p1,&P[i][j].p2,&P[i][j].p3);
			}
		}
		//memset(dp,0,sizeof dp);
		dp[r][c]=0;
		for(int i=r;i>=1;i--)
		for(int j=c;j>=1;j--){
			dp[i][j]=0;
			if(i==r&&j==c||P[i][j].p1==1)continue;
			dp[i][j]=(dp[i+1][j]*P[i][j].p3+dp[i][j+1]*P[i][j].p2+2)/(1-P[i][j].p1);
		}
		printf("%.3f\n",dp[1][1]);
	}
	return 0;
}



概率dp HDU 3853

标签:概率dp

原文地址:http://blog.csdn.net/acvcla/article/details/40457189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!