码迷,mamicode.com
首页 > 其他好文 > 详细

FatMouse and Cheese HDU1078 动态规划,记忆化搜索

时间:2019-09-05 23:15:50      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:ati   ons   his   dimen   cal   can   with   for   fir   

     FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1‘s.
Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input

    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1

Sample Output

    37

#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
#define N 100
int n, k;
int a[N][N], dp[N][N];
int dir[4][2]={0,1,1,0,-1,0,0,-1};
inline pd(int p,int v)
{
    return (p>=0&&p<n &&v>=0 && v<n);
}
int dfs(int x, int y)
{
    if(dp[x][y]!=-1) return dp[x][y];
    dp[x][y]=a[x][y];
    for(int i=0;i<4;++i){
        for(int j=1;j<=k;++j)
        {
            int xx=x+dir[i][0]*j, yy=y+dir[i][1]*j;
            if(pd(xx,yy) && a[xx][yy]>a[x][y]){
                dp[x][y]=max(dp[x][y],a[x][y]+dfs(xx,yy));
            }
        }
    }
    return dp[x][y];
}
int main(void)
{
    while(scanf("%d%d", &n, &k) != EOF && (n != -1 || k != -1)) {
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                scanf("%d", &a[i][j]);

        memset(dp, -1, sizeof(dp));
        printf("%d\n", dfs(0, 0));
    }
    return 0;
}

 

FatMouse and Cheese HDU1078 动态规划,记忆化搜索

标签:ati   ons   his   dimen   cal   can   with   for   fir   

原文地址:https://www.cnblogs.com/LS-Joze/p/11470243.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!