码迷,mamicode.com
首页 > 其他好文 > 详细

DP [HDU 1260] Tickets

时间:2014-10-26 22:34:32      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1191    Accepted Submission(s): 559

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 1) An integer K(1<=K<=2000) representing the total number of people; 2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

 

Sample Input
2 2 20 25 40 1 8
 

 

Sample Output
08:00:40 am 08:00:08 am
 

简单DP、上代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 10010

int n;
int a[N],b[N];
int dp[N]; //dp[i]表示前i个人花的最少时间

int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        dp[1]=a[1];
        dp[2]=min(a[1]+a[2],b[1]);
        for(i=3;i<=n;i++)
        {
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);
        }
        int h=8,m=0,s=0;
        s=dp[n]%60;
        m=dp[n]/60%60;
        h+=dp[n]/3600;
        if(h<12)
            printf("%02d:%02d:%02d am\n",h,m,s);
        else
            printf("%02d:%02d:%02d pm\n",h,m,s);
    }
    return 0;
}

 

DP [HDU 1260] Tickets

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://www.cnblogs.com/hate13/p/4052743.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!