码迷,mamicode.com
首页 > 其他好文 > 详细

C:Dawn-K's water (The Preliminary Contest for ICPC Asia Shenyang 2019)

时间:2019-09-14 22:56:29      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:test   default   pen   board   nsis   this   mat   ++   disco   

Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nn types of mineral water, and he already knew the price pp and the weight cc (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

Input

The input consists of multiple test cases, each test case starts with a number nn (1 \le n \le 10^31n103) -- the number of types, and mm (1 \le m \le 10^41m104) -- the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5e45e4.

Then followed n lines with each line two integers pp (1 \le p \le 10^91p109) -- the price of this type, and cc (1 \le c \le 10^41c104) -- the weight of water this type contains.

Output

For each test case, you should output one line contains the minimum cost aa and the weight of water Dawn-K will get bb. If this minimum cost corresponds different solution, output the maximum weight he can get.

(The answer aa is between 11 and 10^9109, and the answer bb is between 11 and 10^4104)

样例输入

3 3
2 1
3 1
1 1
3 5
2 3
1 2
3 3

样例输出

3 3
3 6


 

#include <iostream>
#include <cmath>
#include <map>
#include <queue>
#include <memory.h>
#include <algorithm>

using namespace std;

long long w[1010],v[1010],arc[10010];

int main()
{
    std::ios::sync_with_stdio(false);
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=0;i<10010;i++)
            arc[i]=1e10+100;
        arc[0]=0;
        for(int i=0;i<n;i++)
            cin>>w[i]>>v[i];
        for(int i=0;i<n;i++)
        {
            for(int j=v[i];j<=10000;j++)
            {
                arc[j]=min(arc[j],arc[j-v[i]]+w[i]);
            }
        }
        int mini=m;
        for(int i=m+1;i<=10000;i++)
        {
            if(arc[i]<=arc[m]&&arc[i]<=arc[mini])
            {
                mini=i;
            }
        }
        cout<<arc[mini]<< <<mini<<endl;
    }
    return 0;
}

 

C:Dawn-K's water (The Preliminary Contest for ICPC Asia Shenyang 2019)

标签:test   default   pen   board   nsis   this   mat   ++   disco   

原文地址:https://www.cnblogs.com/Shallow-dream/p/11520294.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!