码迷,mamicode.com
首页 > 其他好文 > 详细

TZOJ 1822 Sticks DFS加剪枝

时间:2019-09-22 15:06:27      阅读:68      评论:0      收藏:0      [点我收藏+]

标签:The   expr   pos   tin   using   第一个   pac   输出   ssi   

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

输入

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

输出

The output should contains the smallest possible length of original sticks, one per line.

 

样例输入

 

 9

5 2 1 5 2 1 5 2 1

4

1 2 3 4

0

 

样例输出

 

 6

 5

题意:将下面组成一样的长度(最小)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int Max = 65;
 
int n, len, stick[Max];
bool flag, vis[Max];
 
bool cmp(int a, int b)
{
    return a > b;
}
 
void dfs(int dep, int now_len, int u)
{   // dep为当前已被用过的小棒数,u为当前要处理的小棒。
    if(flag) return;//完成的递归返回条件
    if(now_len == 0){                    //  当前长度为0,寻找下一个当前最长小棒。
        int k = 0;
        while(vis[k]) k ++;              //  寻找第一个当前最长小棒。
        vis[k] = true;
        dfs(dep + 1, stick[k], k + 1);
        vis[k] = false;
        return;
    }
    if(now_len == len)
    {                  //  当前长度为len,即又拼凑成了一根原棒。
        if(dep == n) flag = true;        //  完成的标志:所有的n根小棒都有拼到了。
        else dfs(dep, 0, 0);
        return;//未完成的递归返回条件
    }
    for(int i = u; i < n; i ++)
        if(!vis[i] && now_len + stick[i] <= len)// 过滤条件
        {
            if(!vis[i-1] && stick[i] == stick[i-1]) continue;      //  不重复搜索:最重要的剪枝。
            vis[i] = true;
            dfs(dep + 1, now_len + stick[i], i + 1);
            vis[i] = false;
        }
}
 
int main()
{
    while(scanf("%d", &n) && n != 0)
    {
        int sum = 0;
        flag = false;
        for(int i = 0; i < n; i ++)
        {
            scanf("%d", &stick[i]);
            sum += stick[i];
        }
        sort(stick, stick + n, cmp);     //  从大到小排序。
        for(len = stick[0]; len < sum; len ++)
            if(sum % len == 0)//   这里也相当于是剪枝(过滤条件)
            {          //  枚举能被sum整除的长度。
                memset(vis, 0, sizeof(vis));
                dfs(0, 0, 0);
                if(flag) break;
            }
        printf("%d\n", len);
    }
    return 0;
}

 

 

TZOJ 1822 Sticks DFS加剪枝

标签:The   expr   pos   tin   using   第一个   pac   输出   ssi   

原文地址:https://www.cnblogs.com/lhlccc/p/11567342.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!