码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1018:Big Number (位数递推公式)

时间:2019-09-29 23:35:48      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:des   cas   for   ati   col   term   which   name   input   

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

 

#include <cstdio>
#include <string.h>
#define N 1024
#define MAXN 0x3f3f3f3f
#include <map>
#include <string>
#include <cmath>
#define pi acos(-1.0)
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <set>
using namespace std;
int main()
{
    int n,m,t;
    cin>>t;
    while(t--)
    {
        double sum=0;
        cin>>n;
        for(double i=1;i<=n;i++)
            sum+=log10(i);
        cout<<(int)sum+1<<endl;

    }
    return 0;
}

 

HDU 1018:Big Number (位数递推公式)

标签:des   cas   for   ati   col   term   which   name   input   

原文地址:https://www.cnblogs.com/Shallow-dream/p/11610481.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!