码迷,mamicode.com
首页 > 其他好文 > 详细

PTA(Basic Level)1029.旧键盘

时间:2019-09-30 21:41:31      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:namespace   一段   下划线   test   tps   键盘   输入   main   https   

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:

输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

输出格式:

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

输入样例:
7_This_is_a_test
_hs_s_a_es
输出样例:
7TI
思路
  • 遍历找出在应该输入的字符串中没有出现的字符
  • 每次找到一个字符要看有没有在答案里(去重
代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
    string right, wrong;
    cin >> right;
    cin >> wrong;

    string ans = "";
    for(int i=0;i<right.size();i++)
    {
        bool f = true;
        for(int j=0;j<wrong.size();j++)
            if(right[i] == wrong[j])
                f = false;
        if(f)    //说明没找到
        {
            char ch = toupper(right[i]);
            bool exist = false;
            for(int k=0;k<ans.size();k++)
                if(ch == ans[k])
                    exist = true;
            if(!exist)
                ans += ch;
        }
    }
    cout << ans;
    return 0;
}
引用

https://pintia.cn/problem-sets/994805260223102976/problems/994805292322111488

PTA(Basic Level)1029.旧键盘

标签:namespace   一段   下划线   test   tps   键盘   输入   main   https   

原文地址:https://www.cnblogs.com/MartinLwx/p/11614144.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!