码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1213How Many Tables

时间:2014-10-27 21:22:04      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   os   ar   java   for   sp   

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14169    Accepted Submission(s): 6949


Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

裸的并查集。。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 5009

using namespace std;
int fa[N];
int t,n,m;
int a,b;

int find(int a)
{
    if(fa[a]!=a)
    return fa[a]=find(fa[a]);
}

void uniontwo(int a,int b)
{
    int aa=find(a);
    int bb=find(b);
    if(aa>bb) fa[aa]=bb;
    else fa[bb]=aa;
}

int main()
{
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%d",&n,&m);

            for(int i=1;i<=n;i++)
                fa[i]=i;

            for(int i=1;i<=m;i++)
            {
                scanf("%d %d",&a,&b);
                if(fa[a]!=fa[b])
                uniontwo(a,b);
            }

            int ans=0;
            for(int i=1;i<=n;i++)
            {
                if(fa[i]==i)
                ans++;
            }
            cout<<ans<<endl;
        }
    }
    return 0;
}





HDU 1213How Many Tables

标签:des   style   io   color   os   ar   java   for   sp   

原文地址:http://blog.csdn.net/wust_zjx/article/details/40513053

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!