码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1073 Online Judge

时间:2014-10-27 22:59:49      阅读:4167      评论:0      收藏:0      [点我收藏+]

标签:hdu1073

Online Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5373    Accepted Submission(s): 2054


Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user‘s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(‘ ‘), tabs(‘\t‘), or enters(‘\n‘), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user‘s result file, your task is to determine which result the Judge System will return.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user‘s result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
 

Output
For each test cases, you should output the the result Judge System should return.
 

Sample Input
4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END
 

Sample Output
Presentation Error Presentation Error Wrong Answer Presentation Error
 

Author
Ignatius.L
 

#include <stdio.h>
#include <string.h>

#define maxn 5010

char str0[maxn], str1[maxn], buf[maxn];

bool isKong(char ch) {
	return ch == ' ' || ch == '\n' || ch == '\t';
}

int main() {
	//freopen("stdin.txt", "r", stdin);
	int t, mode, id0, id1, i, j;
	bool PE, WA;
	scanf("%d", &t);
	while(t--) {
		mode = id1 = id0 = 0;
		PE = WA = false;
		while(gets(buf)) {
			if(!strcmp(buf, "START"))
				continue;
			else if(!strcmp(buf, "END")) {
				if(++mode == 2) break;
				else continue;
			}
			if(0 == mode) {
				for(i = 0; buf[i]; ++i)
					str0[id0++] = buf[i];
				str0[id0++] = '\n';
				str0[id0] = '\0';
			} else {
				for(i = 0; buf[i]; ++i)
					str1[id1++] = buf[i];
				str1[id1++] = '\n';
				str1[id1] = '\0';
			}
		}
		if(id0 != id1) PE = true;
		for(i = j = 0; i < id0 && j < id1; ) {
			bool flag = 0;			
			if(str0[i] != str1[j] && !PE)
				PE = true;
			if(isKong(str0[i])) {
				++i; flag = 1;
			}
			if(isKong(str1[j])) {
				++j; flag = 1;
			}
			if(flag) continue;
			if(str0[i++] != str1[j++]) {
				if(t == 1) printf("%c%c\n", str0[i-1]);
				WA = true; break;
			}
		}
		
		if(WA) {
			printf("Wrong Answer\n");
			continue;
		} 
		while(i < id0) {
			PE = true;
			if(isKong(str0[i++]))
				continue;
			WA = true; break;
		}
		while(j < id1) {
			PE = true;
			if(isKong(str1[j++]))
				continue;
			WA = true; break;
		}
		if(WA) {
			printf("Wrong Answer\n");
			continue;
		} else if(PE) {
			printf("Presentation Error\n");
			continue;
		}
		printf("Accepted\n");
	}
	return 0;
}


HDU1073 Online Judge

标签:hdu1073

原文地址:http://blog.csdn.net/chang_mu/article/details/40517949

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!