码迷,mamicode.com
首页 > 其他好文 > 详细

Lake Counting (POJ - 2386)

时间:2019-10-09 19:55:38      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:like   desc   put   man   include   min   square   for   ide   

Description

Due to recent rains, water has pooled in various places in Farmer John‘s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W‘) or dry land (‘.‘). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John‘s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John‘s field. Each character is either ‘W‘ or ‘.‘. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John‘s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
#include <iostream>
using namespace std;

char Map[110][110];
bool vis[110][110];
int dir[8][2] = {{1,0},{1,1},{0,1},{1,-1},{-1,0},{-1,-1},{0,-1},{-1,1}};
int dx, dy;
int n, m;

int dfs(int x, int y)
{
	if(x < 0 || x >= n || y < 0 || y >= m)
		return 0;
		
	for(int i = 0; i < 8; ++ i)
	{
		dx = x + dir[i][0];
		dy = y + dir[i][1];
		if(Map[dx][dy] == ‘W‘ && !vis[dx][dy])	
		{
			vis[dx][dy] = true;
			dfs(dx, dy);
		}
	}
}

int main()
{
	int result = 0;
	cin >> n >> m;
	for(int i = 0; i < n; ++ i)
	{
		cin >> Map[i];
	}
	
	for(int i = 0; i < n; ++ i)
	{
		for(int j = 0; j < m; ++ j)
		{
			if(Map[i][j] == ‘W‘ && !vis[i][j])
			{
				vis[i][j] = true;
				dfs(i, j);
				result ++;
			}
		}
	}
	cout << result << endl;
	
	return 0;
}

  

Lake Counting (POJ - 2386)

标签:like   desc   put   man   include   min   square   for   ide   

原文地址:https://www.cnblogs.com/mjn1/p/11643416.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!