标签:only using name span mic out nbsp scanf code
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
Source
思路:很明显的kmp题
#include<bits/stdc++.h>
using namespace std;
#define ll long long
const ll inf = 2000000000000;
const int mod = 1000000007;
const int maxn = 1000 + 8;
int n, m, k, t, ne[10000 + 8];
int a[1000000 + 8], b[10000 + 8];
void getnext()
{
ne[0] = ne[1] = 0;
for(int i = 1; i < m; i++)
{
int j = ne[i];///
while(j && b[i] != b[j])
j = ne[j];
ne[i + 1] = b[i] == b[j] ? j + 1 : 0;///如果两个字母相同,则i和j都加加;否则j = 0,重新比较
}
}
int kmp()
{
int j = 0;
for(int i = 0; i < n; i++)
{
while(j && b[j] != a[i])///如果匹配不成功
j = ne[j];
if(a[i] == b[j])
j++;
if(j == m)
return i - m + 2;
}
return -1;
}
int main()
{
scanf("%d", &t);
while(t--)
{
memset(ne, 0, sizeof(ne));
scanf("%d%d", &n, &m);
for(int i = 0; i < n; i++)
scanf("%d", &a[i]);
for(int i = 0; i < m; i++)
scanf("%d", &b[i]);
getnext();
k = kmp();
printf("%d\n", k);
}
return 0;
}
HDU 1711 Number Sequence(KMP)
标签:only using name span mic out nbsp scanf code
原文地址:https://www.cnblogs.com/RootVount/p/11650020.html