码迷,mamicode.com
首页 > 其他好文 > 详细

PTA(Advanced Level)1011.World Cup Betting

时间:2019-10-13 00:20:33      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:ati   ttl   pre   first   printf   cat   info   time   oss   

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner‘s odd would be the product of the three odds times 65%.

For example, 3 games‘ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%?1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
思路
  • 简单来说题意就是:给定W,S,L的值,每次都找最大的(设为\(x_n\)),最后要求的就是:\((x_1*x_2*...x_n*0.65-1)*2\)
代码
#include<bits/stdc++.h>
using namespace std;
int get_max(int x, int y, int z)
{
    if(x >= y && x >= z)
        return 1;
    if(y >= x && y >= z)
        return 2;
    if(z >= x && z >= y)
        return 3;
}
int main()
{
    double w,t,l;
    double ans = 1.0;

    int cond;
    while(cin>>w>>t>>l)
    {
        cond = get_max(w,t,l);
        switch(cond)
        {
            case 1: cout << "W "; ans *= w; break;
            case 2: cout << "T "; ans *= t; break;
            case 3: cout << "L "; ans *= l; break;
        }
    }
    ans *= 0.65;
    ans -= 1;
    ans *= 2;
    printf("%.2f\n", ans);
    return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805504927186944

PTA(Advanced Level)1011.World Cup Betting

标签:ati   ttl   pre   first   printf   cat   info   time   oss   

原文地址:https://www.cnblogs.com/MartinLwx/p/11664395.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!