码迷,mamicode.com
首页 > 其他好文 > 详细

【博弈论】Euclid's Game

时间:2019-10-22 20:12:40      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:img   pre   second   nbsp   cond   names   alter   lin   输入   

题目描述:

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

         25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

输入

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

输出

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

样例输入

34 12
15 24
0 0

样例输出 

Stan wins
Ollie wins

分析:设a>b,若a%b=0,先手必赢。若a>2*b,可以知道a%b,b是必胜态还是必输态,那么先手就可以决定谁先到达a%b,b这个状态,所以先手必赢。当b<a<2*b时,则需一步步走到0为止。

技术图片
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b) == 2)
    {
        if( a == 0 && b == 0)break;
        if( a < b)swap(a,b);
        int win = 0;
        while(b)
        {
            if( a%b == 0 || a/b >= 2)break;
            a = a-b;
            swap(a,b);
            win ^= 1;
        }
        if(win == 0)printf("Stan wins\n");
        else printf("Ollie wins\n");
    }
    return 0;
}
View Code

 

【博弈论】Euclid's Game

标签:img   pre   second   nbsp   cond   names   alter   lin   输入   

原文地址:https://www.cnblogs.com/xyfs99/p/11722093.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!