码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 5074

时间:2014-10-28 21:17:37      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   os   ar   for   

Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.

bubuko.com,布布扣

Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a1, a2, . . . , an, is simply the sum of score(ai, ai+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

 

Output
For each test case, output the answer in one line.
 

 

Sample Input
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

 

Sample Output
270 625
 

 

Source
 

 分析:记dp[i][j]为第i位取第j位的最大值

bubuko.com,布布扣
#include "stdio.h"
#include "string.h"
#define MAX 110
int a[MAX];
int dp[MAX][MAX],g[MAX][MAX];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t;
    int i,j,k,n,m;
    int ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1; i<=m; i++)
            for(j=1; j<=m; j++)
                scanf("%d",&g[i][j]);
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(i=2; i<=n; i++)
        {
            if(a[i]>0)
            {
                if(a[i-1]>0)
                     dp[i][a[i]]=max(dp[i][a[i]],dp[i-1][a[i-1]]+g[a[i-1]][a[i]]);
                else
                {
                    for(j=1; j<=m; j++)
                        dp[i][a[i]]=max(dp[i][a[i]],dp[i-1][j]+g[j][a[i]]);
                }
            }
            else
            {
                if(a[i-1]>0)
                {
                    for(j=1; j<=m; j++)
                        dp[i][j]=max(dp[i][j],dp[i-1][a[i-1]]+g[a[i-1]][j]);
                }
                else
                {
                    for(j=1; j<=m; j++)
                        for(k=1; k<=m; k++)
                            dp[i][k]=max(dp[i][k],dp[i-1][j]+g[j][k]);
                }
            }
        }
        ans=0;
        for(i=1; i<=m; i++)
            ans=max(ans,dp[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

hdoj 5074

标签:des   style   blog   http   io   color   os   ar   for   

原文地址:http://www.cnblogs.com/Blundering-Chen/p/4057711.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!