码迷,mamicode.com
首页 > 其他好文 > 详细

7-31 jmu-分段函数l (20 分)

时间:2019-11-08 12:33:47      阅读:633      评论:0      收藏:0      [点我收藏+]

标签:com   NPU   use   小数   orm   http   int   python   ima   

本题目要求计算以下分段函数的值(x为从键盘输入的一个任意实数):

技术图片

如果输入非数字,则输出“Input Error!”

输入格式:

在一行中输入一个实数x。

输出格式:

在一行中按”y=result”的格式输出,其中result保留两位小数。

输入样例:

-2

输出样例:

在这里给出相应的输出。例如:

y=3.00
def demo1(x):
    if x > 1:
        y = 2 * x + 1
    elif x > -2:
        y = 3
    else:
        y = -2 * x - 1
    print("y={:.2f}".format(y))


try:
    x = eval(input())
    demo1(x)
except Exception as result:
    print("Input Error!")

  

7-31 jmu-分段函数l (20 分)

标签:com   NPU   use   小数   orm   http   int   python   ima   

原文地址:https://www.cnblogs.com/aimilu/p/11819121.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!