码迷,mamicode.com
首页 > 其他好文 > 详细

1410282310-hd-Seinfeld

时间:2014-10-29 19:26:40      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   os   ar   java   for   sp   



Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1413    Accepted Submission(s): 697


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
}{ {}{}{} {{{} ---
 

Sample Output
1. 2 2. 0 3. 1
 题目大意
        有一堆括号,{}这样算配对,{{,}},}{这样都算不配对,对于一组不配对的括号,可以通过变化括号的方向来使其配对,变一个算一次,求最少的变化次数。
解题思路
       对于{}这种情况,可以将其略去。这样不配对的括号组可以有以下三种情况1.{{{{2.}}}}3.}}}}{{{{当然也可以合并为一种情况n...}{...m。对于}}或者{{只需改变一次,而对于}{则须改变两次。
      这道题主要用到了栈的知识。
代码
#include<stdio.h>
#include<string.h>
char s[2200],c[2200];
int main()
{
	int len1,len2,len3;
	int i,j,k=1;
	int sum,top;
	while(scanf("%s",s)&&s[0]!='-')
	{
		len1=strlen(s);
		top=1;
		memset(c,0,sizeof(c)); 
		c[0]=s[0];
		for(i=1;i<len1;i++)
		{
			c[top]=s[i];
			//if(s[i-1]=='{'&&s[i]=='}')   错误之处 
			//测试数据{{}}
			if(c[top-1]=='{'&&c[top]=='}')
			//是否入栈是让栈组比较的。 
			    top--;
			else
				top++;
		}
		len2=0;
		for(i=0;i<top;i++)
		{
		    if(c[i]=='}')
		        len2++;
		    else
		        break;
		}
		len3=top-len2;
		/*if(len1%2==0)
		    sum=len1/2+len2/2;
		else
		    sum=len1/2+len2/2+2; 
		这样判断的话要额外考虑栈为空的情况*/ 
		sum=(len2+1)/2+(len3+1)/2;
		printf("%d. ",k);
		k++;
		printf("%d\n",sum);
	}
	return 0;
} 

 

1410282310-hd-Seinfeld

标签:des   style   io   color   os   ar   java   for   sp   

原文地址:http://blog.csdn.net/wangluoershixiong/article/details/40589243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!