码迷,mamicode.com
首页 > 其他好文 > 详细

安装 openmpi 4.0 用与 horovod 编译

时间:2019-11-15 22:07:50      阅读:43      评论:0      收藏:0      [点我收藏+]

标签:release   自身   --   down   更新   make   install   https   手动   

最近编译 horovod框架过程中,需要使用openmpi 4.0但是环境中的openmpi版本比较低,所以在手动安装openmpi4.0 用于编译,下面对过程进行简要记录,进行备忘:

  • curl -O -L https://download.open-mpi.org/release/open-mpi/v4.0/openmpi-4.0.1.tar.gz
  • tar xvzf openmpi-4.0.1.tar.gz 
  • ./configure --prefix=/usr/local (--prefix 用于配置自身环境中安装的位置) 
  • make all; make install;
  • 配置环境变量,指向安装的位置即可;export PATH=路径:$PATH;

保持更新,转载请注明出处 cnblogs.com/xuyaowen; 如果您编译过程中遇到什么难以解决的问题,欢迎留言交流;

安装 openmpi 4.0 用与 horovod 编译

标签:release   自身   --   down   更新   make   install   https   手动   

原文地址:https://www.cnblogs.com/xuyaowen/p/openmpi-40-install.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!