码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2773(容斥原理)

时间:2014-10-30 00:09:40      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   os   ar   for   

 容斥原理入门题吧。

Happy 2006
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 9798   Accepted: 3341

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source

 
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <string>
#include <queue>
#include <stdlib.h>
using namespace std;

int m,k;
int mark[1001000];
int save[1001000];
int pcnt;
int g[100100];
long long int sum;
int cnt;

void getprime()
{
    //1不是素数
    for(int i=2;i<=1000000;i++)
    {
        if(mark[i]==1) continue;
        save[pcnt++]=i;
        for(int j=i;j<=1000000;j+=i)
            mark[j]=1;
    }
}

void dfs(int n,long long num,int s,long long int key)
{
    if(n==0)
    {
        sum += key/num;
        return ;
    }
    if(s>=cnt) return ;

    for(int i=s;i<cnt;i++)
    {
        if(num*g[i]>key) continue;
        else dfs(n-1,num*g[i],i+1,key);
    }
}

long long int fuc(long long int x)
{
    if(x==1) return 1;

    long long ans=0;

    int sign=0;
    for(int i=1;i<=cnt;i++)
    {
        sum=0;
        if(sign==0)
        {
            dfs(i,1,0,x);
            ans+=sum;
        }
        else
        {
            dfs(i,1,0,x);
            ans-=sum;
        }
        sign=sign^1;
    }

    return x-ans;//这里面应该不会出现负数吧
}

int main()
{
    getprime();
    while(scanf("%d%d",&m,&k)!=EOF)
    {
        //然后就是分解一个数了
        cnt=0;
        for(int i=2;i<=m;i++)
        {
            int flag=0;
            while(m%i==0)
            {
                if(flag==0)
                {
                    g[cnt++]=i;
                }
                flag=1;
                m/=i;
            }
        }
        if(m!=1) g[cnt++]=m;

        //然后就是容斥原理

        int b=0,d=1000000000;
        while(b<d)
        {
            int mid=(b+d)/2;
            int key=fuc(mid);
            if(key>=k) d=mid;
            else b=mid+1;
        }
        printf("%d\n",b);
    }
    return 0;
}

 

poj 2773(容斥原理)

标签:des   style   blog   http   io   color   os   ar   for   

原文地址:http://www.cnblogs.com/chenhuan001/p/4060819.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!