码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3650 & ZJU 2932 & HDU 2719 The Seven Percent Solution(模拟)

时间:2014-10-30 19:12:01      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:poj   zju   zoj   hdu   模拟   

题目链接:

PKU:http://poj.org/problem?id=3650

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1931

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=2719


Description

Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/mailto:foo@bar.orgftp://127.0.0.1/pub/linux, or even just readme.txt that are used to identify a resource, usually on the Internet or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed by two hexadecimal digits representing the ASCII code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.

Character Encoding
" " (space) %20
"!" (exclamation point) %21
"$" (dollar sign) %24
"%" (percent sign) %25
"(" (left parenthesis) %28
")" (right parenthesis) %29
"*" (asterisk) %2a

Input

The input consists of one or more strings, each 1–79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input. The character "#" is used only as an end-of-input marker and will not appear anywhere else in the input. A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.

Output

For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself. Note that the percent-encoding for an asterisk is %2a (with a lowercase "a") rather than %2A (with an uppercase "A").

Sample Input

Happy Joy Joy!
http://icpc.baylor.edu/icpc/
plain_vanilla
(**)
?
the 7% solution
#

Sample Output

Happy%20Joy%20Joy%21
http://icpc.baylor.edu/icpc/
plain_vanilla
%28%2a%2a%29
?
the%207%25%20solution

Source


代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    char s[1000];
    while(gets(s))
    {
        int len = strlen(s);
        if(s[0] =='#' && len == 1)
            break;
        for(int i = 0; i < len; i++)
        {

            if(s[i]==' ')
                printf("%%20");
            else if(s[i] == '!')
                printf("%%21");
            else if(s[i] == '$')
                printf("%%24");
            else if(s[i] == '%')
                printf("%%25");
            else if(s[i] == '(')
                printf("%%28");
            else if(s[i] == ')')
                printf("%%29");
            else if(s[i] == '*')
                printf("%%2a");
            else
                printf("%c",s[i]);
        }
        printf("\n");
    }
    return 0;
}


POJ 3650 & ZJU 2932 & HDU 2719 The Seven Percent Solution(模拟)

标签:poj   zju   zoj   hdu   模拟   

原文地址:http://blog.csdn.net/u012860063/article/details/40624921

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!