码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5037 FROG (贪心)

时间:2014-10-30 21:03:53      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   os   ar   使用   


Problem Description
Once upon a time, there is a little frog called Matt. One day, he came to a river.

The river could be considered as an axis.Matt is standing on the left bank now (at position 0). He wants to cross the river, reach the right bank (at position M). But Matt could only jump for at most L units, for example from 0 to L.

As the God of Nature, you must save this poor frog.There are N rocks lying in the river initially. The size of the rock is negligible. So it can be indicated by a point in the axis. Matt can jump to or from a rock as well as the bank.

You don‘t want to make the things that easy. So you will put some new rocks into the river such that Matt could jump over the river in maximal steps.And you don‘t care the number of rocks you add since you are the God.

Note that Matt is so clever that he always choose the optimal way after you put down all the rocks.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains N, M, L (0<=N<=2*10^5,1<=M<=10^9, 1<=L<=10^9).

And in the following N lines, each line contains one integer within (0, M) indicating the position of rock.
 

Output
For each test case, just output one line “Case #x: y", where x is the case number (starting from 1) and y is the maximal number of steps Matt should jump.
 

Sample Input
2 1 10 5 5 2 10 3 3 6
 

Sample Output
Case #1: 2 Case #2: 4
 

Source

题意:有一条小河长为M的小河,可以看作一维轴,小河里存在N个石头,有一个每次能跳L米的小青蛙,随意添加石头保证青蛙能从头跳到尾的,问青蛙使用最优策略跳到对岸最多需要多少次。

思路:贪心的做法,显然如果每次都让青蛙在L+1的长度跳两次是最优的,那么问题来了:如果要这么跳的话,那么在L+1的地方有一个石子,在[0, L+1]的地方也要有一个位置,但是要考虑到前面青蛙已经跳到的位置,因为我们是希望它只能从0的位置开始跳的,如果前面的位置last+x(这段距离多出来的部分)<L+1的话,那么青蛙就可以跳过这个部分,我觉得画张图比较好理解一点

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 200005;

int n, m, l;
int num[maxn];

int main() {
	int t, cas = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d%d", &n, &m, &l);	
		for (int i = 1; i <= n; i++)
			scanf("%d", &num[i]);
		num[0] = 0, num[++n] = m;

		int ans = 0;
		int last = l;
		sort(num, num+n);
		for (int i = 1; i <= n; i++) {
			int x = (num[i] - num[i-1]) % (l+1);
			int y = (num[i] - num[i-1]) / (l+1);
			if (last + x >= l+1) {
				last = x;
				ans += 2 * y + 1;
			}
			else if (last + x < l+1) {
				last = last + x;
				ans += 2 * y;
			}
		}

		printf("Case #%d: %d\n", cas++, ans);
	}
	return 0;
}






HDU 5037 FROG (贪心)

标签:des   style   blog   http   io   color   os   ar   使用   

原文地址:http://blog.csdn.net/u011345136/article/details/40625181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!