码迷,mamicode.com
首页 > 其他好文 > 详细

UVA Firetruck (DFS)

时间:2014-10-30 22:42:12      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:style   io   color   os   ar   for   sp   div   on   

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)
  • The final line of each test case consists of a pair of 0‘s.

Output

For each test case, your output must identify the case by number (CASE #1CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn‘t want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.

Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.

题意:按字典序输出1~k的所有路径
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<map>
typedef long long LL;
using namespace std;
int mp[25][25];
int visit[25];
int num[25];
int vis[25];
int a[25],sum;
int k,cnt;
void DFS(int cur)
{
    vis[cur]=1;
    a[sum++]=cur;
    for(int i=1;i<=25;i++)
    {
        if(!vis[i]&&mp[cur][i])
            DFS(i);
    }
}
void dfs(int cur,int s)
{
    if(cur==k)
    {
        cnt++;
        for(int i=0;i<s;i++)
            printf(i==0?"%d":" %d",num[i]);
        puts("");
        return ;
    }
    for(int i=1;i<=sum;i++)
    {
        if(mp[cur][a[i]]&&!visit[a[i]])
        {
            visit[a[i]]=1;
            num[s]=a[i];
            dfs(a[i],s+1);
            visit[a[i]]=0;
        }
    }
}
int main()
{
    int l=1;
    while(~scanf("%d",&k))
    {
        int x,y;
        memset(mp,0,sizeof(mp));
        memset(visit,0,sizeof(visit));
        memset(vis,0,sizeof(vis));
        while(~scanf("%d%d",&x,&y)&&(x+y))
            mp[x][y]=mp[y][x]=1;
        sum=0;
        DFS(k);
        sort(a,a+sum);
        num[0]=1;
        visit[1]=1;
        cnt=0;
        printf("CASE %d:\n",l++);
        dfs(1,1);
        printf("There are %d routes from the firestation to streetcorner %d.\n",cnt,k);
    }
    return 0;
}


UVA Firetruck (DFS)

标签:style   io   color   os   ar   for   sp   div   on   

原文地址:http://blog.csdn.net/u013582254/article/details/40627603

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!