标签:des style blog http io color os ar java
Candy
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2115 Accepted Submission(s): 910
Special Judge
Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability
(1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000
Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000
从两个箱子里取糖果,直到发现某一个箱子里的糖果已经取完,求另一个箱子里剩余糖果的期望。
因为取完的箱子选择了N+1次,故为p^(n+1),精度问题可以取对数处理。
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define LL __int64
#define N 400005
const LL mod=1000000007;
double f[N];
double logc(int m,int n) //快速排列组合函数C(n,m)=exp(lggc(n,m));
{
return f[m]-f[n]-f[m-n];
}
int main()
{
double p,q;
int n,i,k,cnt=1;
f[0]=0;
for(i=1;i<N;i++)
f[i]=f[i-1]+log(i*1.0);
while(~scanf("%d%lf",&n,&p))
{
q=1.0-p;
double ans=0;
for(k=0;k<n;k++)
{
ans+=(n-k)*(exp(logc(n+k,k)+(n+1)*log(p)+k*log(q))+exp(logc(n+k,k)+(n+1)*log(q)+k*log(p)));
}
printf("Case %d: %.6f\n",cnt++,ans);
}
return 0;
}
hdu 4465 Candy (快速排列组合 )
标签:des style blog http io color os ar java
原文地址:http://blog.csdn.net/u011721440/article/details/40627297