码迷,mamicode.com
首页 > 其他好文 > 详细

A-Psycho-Pass全场签到题-字符串的操作

时间:2019-12-15 18:26:39      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:ace   ref   namespace   class   problem   put   字符   href   tle   

题目链接:http://acm.csust.edu.cn/problem/3031

Description

 

众所周知,常守朱是一个优秀的执行官,她凭借自身的卓越能力解决了许多案件,当然她手中的支配者也为办案提供了很大的便利,支配者可以测量一个人的犯罪指数,当超过一定值时,则被认为是罪犯。

支配者的工作原理如下:将一个人的脑电波转化为01串(我瞎编的),01串中1的个数越多,则犯罪指数越高,下面给你一个01串,请你统计该串中1的个数

 

Input

 

一个字符串s,字符串的长度小于1e5

 

Output

 

字符串中1的个数

 

Sample Input 1 

0101

Sample Output 1

2


没什么好说的,学了字符串的都会。
以下是AC代码:
#include <bits/stdc++.h>
using namespace std;

const int mac=1e5+10;

char s[mac];

int main()
{
    int nb=0;
    scanf ("%s",s);
    int len=strlen(s);
    for (int i=0; i<len; i++)
        if (s[i]==1) nb++;
    printf ("%d\n",nb);
    return 0;
}

 



A-Psycho-Pass全场签到题-字符串的操作

标签:ace   ref   namespace   class   problem   put   字符   href   tle   

原文地址:https://www.cnblogs.com/lonely-wind-/p/12003637.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!