码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构上机测试2-1:单链表操作A (顺序建表+关键字删除)

时间:2014-10-31 23:45:34      阅读:420      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   color   for   数据   div   2014   

数据结构上机测试2-1:单链表操作A

Time Limit: 1000MS Memory limit: 4096K

题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

输入

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

输出

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

示例输入

10
56 25 12 33 66 54 7 12 33 12
12

示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head,*tail,*p;
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
int del(struct node *head,int key,int n)
{
    struct node *p,*q;
    int flag=0;
    q=head;
    p=head->next;
    while(p!=NULL)
    {
        if(p->data==key)
        {
            q->next=p->next;
            free(p);
            p=q->next;
            n--;
        }
        else
        {
            q=p;
            p=p->next;
        }
    }
    return n;
}
void show(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
            p=p->next;
    }
}
int main()
{
    int n,m,k;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    scanf("%d",&m);
    printf("%d\n",n);
    show(head);
    m=del(head,m,n);
    printf("%d\n",m);
    show(head);
    return 0;
}




数据结构上机测试2-1:单链表操作A (顺序建表+关键字删除)

标签:des   style   blog   io   color   for   数据   div   2014   

原文地址:http://blog.csdn.net/u013486414/article/details/40662399

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!