码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3633 Alice's present(线段树)

时间:2014-11-01 06:19:48      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   os   ar   for   sp   on   

As a doll master, Alice owns a wide range of dolls, and each of them has a number tip on it‘s back, the tip can be treated as a positive integer. (the number can be repeated). One day, Alice hears that her best friend Marisa‘s birthday is coming , so she decides to sent Marisa some dolls for present. Alice puts her dolls in a row and marks them from 1 to n. Each time Alice chooses an interval from i to j in the sequence ( include i and j ) , and then checks the number tips on dolls in the interval from right to left. If any number appears more than once , Alice will treat this interval as unsuitable. Otherwise, this interval will be treated as suitable.

This work is so boring and it will waste Alice a lot of time. So Alice asks you for help .

Input

There are multiple test cases. For each test case:

The first line contains an integer n ( 3≤ n ≤ 500,000) ,indicate the number of dolls which Alice owns.

The second line contains n positive integers , decribe the number tips on dolls. All of them are less than 2^31-1. The third line contains an interger m ( 1 ≤ m ≤ 50,000 ),indicate how many intervals Alice will query. Then followed by m lines, each line contains two integer uv ( 1≤ uv≤ n ),indicate the left endpoint and right endpoint of the interval. Process to the end of input.

Output

For each test case:

For each query, If this interval is suitable , print one line "OK". Otherwise, print one line ,the integer which appears more than once first.

Print an blank line after each case.

Sample Input

5
1 2 3 1 2
3
1 4
1 5
3 5
6
1 2 3 3 2 1
4
1 4
2 5
3 6
4 6

Sample Output

1
2
OK

3
3
3
OK

Hint

Alice will check each interval from right to left, don‘t make mistakes.


题意:给定一个区间,询问区间有木有重复的数。

map一下,表示某个数的靠左边相同的位置,没有置为-1;转化为询问区间最大值。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const int maxn=500000+100;
int t[maxn<<2],a[maxn],b[maxn];
map<int,int>f;
//int hash[maxn];
int n,m;
void pushup(int rs)
{
    t[rs]=max(t[rs<<1],t[rs<<1|1]);
}
void build(int rs,int l,int r)
{
    if(l==r)
    {
        t[rs]=a[l];
        return ;
    }
    int mid=(l+r)>>1;
    build(rs<<1,l,mid);
    build(rs<<1|1,mid+1,r);
    pushup(rs);
}
int query(int rs,int l,int r,int x,int y)
{
    if(x<=l&&y>=r)  return t[rs];
    int mid=(l+r)>>1;
    int res1,res2;
    res1=res2=-1;
    if(x<=mid)  res1=query(rs<<1,l,mid,x,y);
    if(y>mid)   res2=query(rs<<1|1,mid+1,r,x,y);
    return max(res1,res2);
}
int main()
{
    int x,y;
    while(~scanf("%d",&n))
    {
        f.clear();
//        CLEAR(hash,0);
        REPF(i,1,n)
        {
            scanf("%d",&x);
            b[i]=x;
            if(!f[x])
            {
                f[x]=i;
                a[i]=-1;
            }
            else
            {
                a[i]=f[x];
                f[x]=i;
            }
        }
        build(1,1,n);
        scanf("%d",&m);
        REP(i,m)
        {
            scanf("%d%d",&x,&y);
            int ans=query(1,1,n,x,y);
            if(ans<x) puts("OK");
            else  printf("%d\n",b[ans]);
        }
        puts("");
    }
    return 0;
}


ZOJ 3633 Alice's present(线段树)

标签:des   style   io   color   os   ar   for   sp   on   

原文地址:http://blog.csdn.net/u013582254/article/details/40669735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!