码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4450-Draw Something (2012年金华赛区I题)

时间:2014-11-01 13:30:59      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:水题   c++   c语言   algorithm   acm   

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2591    Accepted Submission(s): 2179


Problem Description
Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something.
Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say.
Input all the square Wangpeng draws, what’s the number in the picture?
 

Input
There are multiple test cases.
For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares.
Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap.
Input ends with N = 0.
 

Output
For each case, output the total area in one line.
 

Sample Input
4 1 2 3 4 3 3 3 3 0
 

Sample Output
30 27
 

Source
 


简直水的不行的题目!!

就是求平方和!!


AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int main()
{
	int n, sum;
	while(scanf("%d", &n), n)
	{
		int a;
		sum=0;
		for(int i=0; i<n; i++)
		{
			scanf("%d", &a);
			sum+=a*a;
		}
		printf("%d\n", sum);
	}
	return 0;
} 


HDU-4450-Draw Something (2012年金华赛区I题)

标签:水题   c++   c语言   algorithm   acm   

原文地址:http://blog.csdn.net/u014355480/article/details/40679363

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!