码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构实验之链表六:有序链表的建立

时间:2014-11-01 17:52:31      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   color   ar   使用   for   sp   

数据结构实验之链表六:有序链表的建立

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

输入

第一行输入整数个数N;
第二行输入N个无序的整数。

输出

依次输出有序链表的结点值。

示例输入

6
33 6 22 9 44 5

示例输出

5 6 9 22 33 44

提示

不得使用数组!

来源

 

示例程序

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head,*tail,*p;
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};
void sort(struct node *head,int n)
{
    struct node *p,*q;
    int t;
    for(p=head->next;p!=NULL;p=p->next)
    {
        for(q=p->next;q!=NULL;q=q->next)
        {
            if(p->data>q->data)
            {
                t=p->data;
                p->data=q->data;
                q->data=t;
            }
        }
    }
}
void show(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p=p->next;
    }
}
int main()
{
    int n;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    sort(head,n);
    show(head);
    return 0;
}



数据结构实验之链表六:有序链表的建立

标签:des   style   blog   io   color   ar   使用   for   sp   

原文地址:http://blog.csdn.net/u013486414/article/details/40681519

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!