码迷,mamicode.com
首页 > 其他好文 > 详细

(图论) H - 畅通工程

时间:2020-01-15 14:05:31      阅读:78      评论:0      收藏:0      [点我收藏+]

标签:遍历   contain   bsp   图论   整数   重复   分析   pac   comm   

H - 畅通工程

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 注意:两个城市之间可以有多条道路相通,也就是说

3 3

1 2

1 2

2 1

 

这种输入也是合法的 当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

 

Sample Output

1
0
2
998
?
?

 


       
 
Huge input, scanf is recommended.

题目描述:

有N座城市。要求把他们全部连通,就是从一座城市开始,可以直接或通过其他城市到达另一座城市。给出m条道路,道路可以重复。问至少还需要修多少条路。

分析:

主要是使用并查集。就是找出城市间的关系。找出一个代表a,如果b能到达a,c也能到达a,则b能到达c。

代码:

#include <iostream>
#include <cstdio>
#include <stdlib.h> 
#include <cstring>
using namespace std;
int parent[1000];
//记录根的高度 
int ran[1000];
int findroot(int x)
{
    if(x==parent[x]) return x;
    else
    {
        return findroot(parent[x]);
    }
}
void unit(int x,int y)
{
    int xroot=findroot(x);
    int yroot=findroot(y);
    if(xroot==yroot) return;
    if(ran[xroot]>ran[yroot])
    {
        parent[yroot]=xroot;
    }
    else if(ran[xroot]==ran[yroot])
    {
        parent[yroot]=xroot;
        ran[xroot]++;
    }
    else
    {
        parent[xroot]=yroot;
    }
}
int main()
{
    int n;
    long long m;
    while(1)
    {
        scanf("%d",&n);
        if(n==0) break;
        scanf("%lld",&m);
        //开始各自为它自己的根 
        for(int i=1;i<=n;i++) parent[i]=i;
        memset(ran,0,sizeof(ran));
        for(int i=0;i<m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            //连通2条路 
            unit(a,b); 
        }
        //遍历他们的根,找到有多少个不连通的 
        int ans = 0;
        for (int i = 1; i <= n; ++i)
            if (parent[i] == i)
                ans++;
        printf("%d\n", ans - 1);
    }
    return 0;
} 
?
 

(图论) H - 畅通工程

标签:遍历   contain   bsp   图论   整数   重复   分析   pac   comm   

原文地址:https://www.cnblogs.com/studyshare777/p/12195913.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!