码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1065 A+B and C (64bit) (20分)

时间:2020-01-20 09:30:50      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:pareto   ati   ecif   compare   sed   space   sep   int   a+b   

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
 

Sample Output:

Case #1: false
Case #2: true
Case #3: false

大数用Java比较方便

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int N=sc.nextInt();
        BigInteger A,B,C;
        for(int i=1;i<=N;i++){
            A=sc.nextBigInteger();
            B=sc.nextBigInteger();
            C=sc.nextBigInteger();
            if(A.add(B).compareTo(C)>0){
                System.out.printf("Case #%d: true\n",i);
            }else{
                System.out.printf("Case #%d: false\n",i);
            }
        }
    }
}

PAT Advanced 1065 A+B and C (64bit) (20分)

标签:pareto   ati   ecif   compare   sed   space   sep   int   a+b   

原文地址:https://www.cnblogs.com/littlepage/p/12216124.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!