码迷,mamicode.com
首页 > 其他好文 > 详细

字符串替换

时间:2014-11-02 17:56:39      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:style   blog   io   color   ar   os   for   sp   strong   

字符串替换

描述

编写一个程序实现将字符串中的所有"you"替换成"we"

 
输入
输入包含多行数据 
每行数据是一个字符串,长度不超过1000  数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do

 
#include<iostream>
#include<string>
using namespace std;
int main()
{
string arr;
int m ;
while( getline(cin,arr) && !cin.eof())
{
    m = arr.length();
    for(int i=0;i<m;i++)
    {
    if(arr[i]==y&&arr[i+1]==o&&arr[i+2]==u)
        {
            cout<<"we";
        i +=2;
    }
        else
        
            cout<<arr[i];
    }
    cout<<endl;
}
return 0;
}        

 

字符串替换

标签:style   blog   io   color   ar   os   for   sp   strong   

原文地址:http://www.cnblogs.com/imwtr/p/4069511.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!