码迷,mamicode.com
首页 > 其他好文 > 详细

A problem is easy

时间:2014-11-02 17:57:15      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   io   color   os   for   sp   strong   

A problem is easy

描述

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

bubuko.com,布布扣

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

 
输入
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
输出
For each case, output the number of ways in one line
样例输入
2
1
3
样例输出
0
1

 
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n;
    int a,b;
    cin>>n;
    while(n--)
    {
        cin>>a;
        b=0;
        for(int i=2;i*i<=(a+1);i++)
        {
            int j = (a+1)/i;
            if(i*j==a+1 && i<=j)
        
                b++;
        }
        cout<<b<<endl;
    }
return 0;
}        

 

A problem is easy

标签:style   blog   http   io   color   os   for   sp   strong   

原文地址:http://www.cnblogs.com/imwtr/p/4069528.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!