码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1031 Hello World for U (20分)

时间:2020-01-22 14:29:27      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:using   The   original   ESS   white   length   ret   long   std   

Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo
 

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n?1?? characters, then left to right along the bottom line with n?2?? characters, and finally bottom-up along the vertical line with n?3?? characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n?1??=n?3??=max { k | kn?2?? for all 3 } with n?1??+n?2??+n?3??2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!
 

Sample Output:

h   !
e   d
l   l
lowor

 

这道题目考察了格式化字串,我们需要先补2个位置,除以三,进行计算两边的数量,最后再计算中间的

#include <iostream>
using namespace std;
int main() {
    string str;
    getline(cin, str);
    int row, N = str.length(), recol;
    row = (N + 2) / 3 ;
    recol = (N + 2) / 3 + (N + 2) % 3 - 2;
    for(int i = 0; i < row; i++){
        cout << str[i];
        for(int j = 0; j < recol; j++)
            if(i != row - 1) cout << " ";
            else cout << str[j + row];
        cout << str[N - i -1] << endl;
    }
    return 0;
}

PAT Advanced 1031 Hello World for U (20分)

标签:using   The   original   ESS   white   length   ret   long   std   

原文地址:https://www.cnblogs.com/littlepage/p/12228395.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!