标签:lse pat line which 输出 cut nta length cin
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
?100
?? ).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
个人最初的题解思路是设定字符串常量,求和得出数值后使用if else计算出各位的数字对应输出:
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
int sum = 0;
char str[101];
const char* a[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
cin>>str;
int len=strlen(str);
for(int i=0;i<len;++i)
{
sum = sum+(str[i]-'0');
}
//cout<<sum<<endl;
if(sum>=0&&sum<10)
{
printf("%s",a[sum%10]);
}
else if(sum>10&&sum<100)
{
printf("%s %s",a[sum/10],a[sum%10]);
}
else if(sum>100)
{
printf("%s %s %s",a[sum/100],a[(sum/10)%10],a[sum%10]);
}
return 0;
}
更优的方法是:
#include <iostream>
using namespace std;
int main() {
string a;
cin >> a;
int sum = 0;
for (int i = 0; i < a.length(); i++)
sum += (a[i] - '0');
string s = to_string(sum);
string arr[10] = {"zero", "one", "two", "three", "four", "five", "six",
"seven", "eight", "nine"};
cout << arr[s[0] - '0'];
for (int i = 1; i < s.length(); i++)
cout << " " << arr[s[i] - '0'];
return 0;
}
to_string
函数将数字转为字符串完美解决了各个位置上的数值输出问题
标签:lse pat line which 输出 cut nta length cin
原文地址:https://www.cnblogs.com/mrcangye/p/12231704.html