码迷,mamicode.com
首页 > 其他好文 > 详细

PAT甲级——1035 Password (20分)

时间:2020-01-24 00:29:37      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:clu   lin   include   OWIN   one   rac   好的   instead   file   

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

之前的题解定义了结构体,较为复杂:

 #include<cstdio>
 #include<iostream>
 #include<cstring>
 using namespace std;
  
  
struct Users{
    char num[20];
    char pass[20];
    bool flag = false;
}user[1005];
int main()
  
  {
    int N; 
    int sum=0;
    scanf("%d",&N);
    int i,j;
    for(i=0;i<N;i++)
    {
        scanf("%s %s",user[i].num,user[i].pass);
        for( j=0;j<strlen(user[i].pass);j++)
        {
            if(user[i].flag!=true)
            {
            if(user[i].pass[j]=='1') {user[i].pass[j]='@';user[i].flag=true;break;}
            if(user[i].pass[j]=='0') {user[i].pass[j]='%';user[i].flag=true;break;}
            if(user[i].pass[j]=='l') {user[i].pass[j]='L';user[i].flag=true;break;}
            if(user[i].pass[j]=='O') {user[i].pass[j]='o';user[i].flag=true;break;}
            
              }
            if(user[i].flag==true)
            {
                sum++;
                break;
            }

            
          }
      }
      
    if(sum)
    {
        printf("%d",sum);
        for(int i=0;i<N;i++)
        {
            if(user[i].flag==true)
            {
            printf("\n");
            printf("%s %s",user[i].num,user[i].pass);   
              }

          }
      }
      else
      {
        if(N==1)
        {
            printf("There is 1 account and no account is modified");
          }
          else
          {
            printf("There are %d accounts and no account is modified",N);
          }
      }
   } 

更好的是:

#include <iostream>
#include <vector>
using namespace std;
int main() {
         int n;
         scanf("%d", &n);
         vector<string> v;
         for(int i = 0; i < n; i++) {
                 string name, s;
                 cin >> name >> s;
                 int len = s.length(), flag = 0;
                 for(int j = 0; j < len; j++) {
                         switch(s[j]) {
                                 case '1' : s[j] = '@'; flag = 1; break;
                                 case '0' : s[j] = '%'; flag = 1; break;
                                 case 'l' : s[j] = 'L'; flag = 1; break;
                                 case 'O' : s[j] = 'o'; flag = 1; break;
                         }
                  }
         if(flag) {
                 string temp = name + " " + s;
                 v.push_back(temp);
             }
         }
         int cnt = v.size();
         if(cnt != 0) {
                 printf("%d\n", cnt);
                 for(int i = 0; i < cnt; i++)
                 cout << v[i] << endl;
         } 
        else if(n == 1) {
                 printf("There is 1 account and no account is modified");
         } 
        else {
                 printf("There are %d accounts and no account is modified", n);
         }
             return 0;
}

使用C++里的vectorstring组合将题目解出,省去了使用结构体的麻烦

PAT甲级——1035 Password (20分)

标签:clu   lin   include   OWIN   one   rac   好的   instead   file   

原文地址:https://www.cnblogs.com/mrcangye/p/12231725.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!