码迷,mamicode.com
首页 > 其他好文 > 详细

1008 Elevator (20分)

时间:2020-01-26 23:53:52      阅读:68      评论:0      收藏:0      [点我收藏+]

标签:positive   output   lis   request   round   ati   contains   namespace   题意   

1008 Elevator (20分)

题目:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题意:

电梯上楼需要6秒,下楼需要4秒并且再每一层会停留5秒。题目给N个数字代表楼层,计算总共需要多少秒。

例子:上二楼需要12秒,再上一层6秒,下到1层8秒,每一层停留5秒一共15秒加起来:12+6+8+15=41。

题解:

#include <iostream>
using namespace std;
int main() {
    int n,ans = 0,tmp,now = 0;
    cin >> n;
    ans += n*5;
    for(int i=0;i<n;i++) {
        cin >> tmp;
        if(tmp > now) {
            ans += (tmp - now) * 6;
            now = tmp;
        }
        else {
            ans += (now - tmp) * 4;
            now = tmp;
        }
    }
    cout << ans << endl;
    return 0;
}

1008 Elevator (20分)

标签:positive   output   lis   request   round   ati   contains   namespace   题意   

原文地址:https://www.cnblogs.com/F4lc0n/p/12235254.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!