码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1062 text reverse

时间:2020-01-27 15:40:56      阅读:55      评论:0      收藏:0      [点我收藏+]

标签:stack   cas   har   end   name   main   else   proc   ane   

 咳咳,这个是为了赶量

需要注意的就是输入方式,别的也没什么难点

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

 

Output
For each test case, you should output the text which is processed.
 

 

Sample Input
3
olleh !dlrow
m‘I morf .udh
I ekil .mca
 

 

Sample Output
hello world!
I‘m from hdu.
I like acm.
这是题意
接下来放代码

#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;

int main(){
int n;
cin >> n;
getchar();
while(n--){
stack<char>cst;
while(1){
int ch=getchar();
if(ch==‘ ‘||ch==‘\n‘){
while(!cst.empty()){
cout << cst.top();
cst.pop();
}
if(ch==‘ ‘)cout << ‘ ‘;
else break;
}
else cst.push(ch);
}
cout << endl;
}
return 0;
}

OK

hdu1062 text reverse

标签:stack   cas   har   end   name   main   else   proc   ane   

原文地址:https://www.cnblogs.com/sos3210/p/12236034.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!