码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1144 The Missing Number (20分)

时间:2020-01-27 17:28:02      阅读:71      评论:0      收藏:0      [点我收藏+]

标签:lan   namespace   color   map   sam   mis   lin   numbers   ber   

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17
 

Sample Output:

7

这道题考察了哈希映射。映射到哈希表中,之后进行从1开始判断,输出最小不存在的数字。

#include <iostream>
#include <map>
using namespace std;
int main(){
    int N, tmp;
    map<int, bool> m;
    cin >> N;
    while(N--){
        cin >> tmp;
        m[tmp] = true;
    }
    int i = 1;
    while(m[i]) i++;
    cout << i;
    return 0;
}

 

PAT Advanced 1144 The Missing Number (20分)

标签:lan   namespace   color   map   sam   mis   lin   numbers   ber   

原文地址:https://www.cnblogs.com/littlepage/p/12236214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!