码迷,mamicode.com
首页 > 其他好文 > 详细

stack的使用-Hdu 1062

时间:2020-01-27 21:59:24      阅读:67      评论:0      收藏:0      [点我收藏+]

标签:pac   reverse   write   inpu   time   模拟   strong   --   字符串   

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51495    Accepted Submission(s): 19692


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

 

Output
For each test case, you should output the text which is processed.
 

 

Sample Input
3 olleh !dlrow m‘I morf .udh I ekil .mca
 

 

Sample Output
hello world! I‘m from hdu. I like acm.
 
首先这个题就是简单的字符串反转,注意点是遇到空格怎么处理,用STL中的栈来模拟
代码:
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n;
    char ch;
    cin>>n;
    getchar();
    while(n--){
        stack<char>s;
        while(true){
            ch = getchar();
            if(ch== ||ch==\n||ch==EOF){
                while(!s.empty()){
                    cout<<s.top();
                    s.pop();
                } 
                if(ch==\n||ch==EOF)
                    break;
                cout<<" ";
            }
            else
                s.push(ch);
        }
        cout<<endl;
    }
    return 0;
}

 

stack的使用-Hdu 1062

标签:pac   reverse   write   inpu   time   模拟   strong   --   字符串   

原文地址:https://www.cnblogs.com/jingshixin/p/12236843.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!