码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1028 List Sorting (25分)

时间:2020-01-28 23:03:34      阅读:83      评论:0      收藏:0      [点我收藏+]

标签:UNC   using   bottom   nes   排序   int   function   you   color   

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student‘s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID‘s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID‘s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
 

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90
 

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
 

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
 

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
 

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

输入M条信息,对第choose列进行从小到大排序,如果choose列相同,那么从小到大排序id

如果有超时,检查一下比较函数是否加上引用传递&

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int choose;
bool cmp(vector<string>& s, vector<string>& s2){
    return s[choose] == s2[choose] ? s[1] < s2[1]: s[choose] < s2[choose];
}
int main() {
    int M;
    cin >> M >> choose;
    vector<string> s[M];
    for(int  i= 0; i < M; i++){
        s[i].resize(4);
        cin >> s[i][1] >> s[i][2] >> s[i][3];
    }
    sort(s, s+M, cmp);
    for(int  i= 0; i < M; i++)
        printf("%s %s %s\n", s[i][1].data(),
               s[i][2].data(), s[i][3].data());
    return 0;
}

PAT Advanced 1028 List Sorting (25分)

标签:UNC   using   bottom   nes   排序   int   function   you   color   

原文地址:https://www.cnblogs.com/littlepage/p/12239074.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!