码迷,mamicode.com
首页 > 其他好文 > 详细

假期编程

时间:2020-01-30 17:15:24      阅读:49      评论:0      收藏:0      [点我收藏+]

标签:src   scan   aik   width   get   jpg   NPU   ati   str   

1.两点间距离(10min)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2001

Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组输入数据,输出一行,结果保留两位小数。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
Author

题解:

此题需要知道两点间距离公式:|

设两个点A、B以及坐标分别为
技术图片
技术图片
,则A和B两点之间的距离为:
技术图片
代码如下:
#include<stdio.h>
#include<math.h>
int main(void)
{
    double x1,x2,y1,y2;
    double dis;
    double temp;
    while(~scanf("%lf %lf %lf %lf",&x1,&y1,&x2,&y2))
    {
       dis=0;
       temp=(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
       
       dis=sqrt(temp);
       printf("%0.2lf\n",dis);
    
    }
  
    return 0;
    
}

2.

假期编程

标签:src   scan   aik   width   get   jpg   NPU   ati   str   

原文地址:https://www.cnblogs.com/ping2yingshi/p/12243098.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!